How To Fix YUM Update Errors with Percona GPG Keys

Published Date Author: , Posted April 16th, 2019 at 9:12:13am

Problem: Trying to run a yum -y update as root aborts with the following error:

1
2
3
4
5
The GPG keys listed for the "Percona-Release YUM repository - x86_64" repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.
 
 Failing package is: sysbench-1.0.17-2.el6.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-Percona
The GPG keys listed for the "Percona-Release YUM repository - x86_64" repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.

 Failing package is: sysbench-1.0.17-2.el6.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-Percona

The solution, found on the Percona website, is this:

sudo yum update percona-release

Source URL: https://www.percona.com/blog/2019/02/05/new-percona-package-signing-key-requires-update-on-rhel-and-centos/

No comments as yet.

Leave Your Comment  Leave a comment

All fields marked with "*" are required.